Intermittent email delivery delay
Incident Report for Piano Software
Resolved
This incident has been resolved.
Posted May 01, 2021 - 17:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 01, 2021 - 14:55 UTC
Identified
Increased delay of email delivery via Mandrill. SES clients are not affected.
Posted May 01, 2021 - 14:45 UTC
This incident affected: Email Distribution (Piano ID and VX transactional Emails).