Piano dashboard reporting is experiencing high latency on some requests
Incident Report for Piano Software
Resolved
Email reporting functionality is fully functional.
Posted Mar 03, 2021 - 10:07 UTC
Investigating
Engineering team is investigating.
Posted Mar 03, 2021 - 04:03 UTC
This incident affected: Dashboards, Interfaces and Platform (Publisher Dashboard - US - https://dashboard.piano.io).