Increased latency and dropped requests due to Cloudflare incident
Incident Report for Piano Software
Resolved
Traffic levels and responses are back to normal. Cloudflare has marked the issue as resolved. We will continue to monitor the situation and slowly re-enable Cloudflare proxies.

https://www.cloudflarestatus.com/incidents/46z55mdhg0t5
Posted Jun 24, 2019 - 13:07 UTC
Update
Traffic levels and responses are back to normal however we continue to monitor the Cloudflare incident. https://www.cloudflarestatus.com/incidents/46z55mdhg0t5
Posted Jun 24, 2019 - 12:38 UTC
Investigating
Piano customers are currently experiencing increased latency on Composer and Dashboard requests. The issue is related to a Cloudflare issue. Our engineers are investigating and will provide updates as we learn more.
Posted Jun 24, 2019 - 12:24 UTC
This incident affected: Dashboards, Interfaces and Platform (Publisher Dashboard - US - https://dashboard.piano.io), Payments (VX Checkout - US - buy.piano.io), and Composer Experience Execution (Composer Experience Execution - US).