Piano platform is experiencing high latency on some requests
Incident Report for Piano Software
Resolved
Piano Engineers removed traffic routing from the impacted servers where possible and ensured no downtime of service. Now that the impacted AWS zone is running again, async services are processing as normal.
Posted Jul 28, 2020 - 11:32 UTC
Identified
AWS is having an outage which is causing asynchronous jobs to fail in Piano - Functionality affected includes; Webhooks, granting of access through the Dashboard, user imports. Piano Engineers are working to bypass this AWS error where possible. For more information see: https://status.aws.amazon.com.

An update will follow within an hour or as soon as the incident at AWS is resolved.
Posted Jul 28, 2020 - 10:18 UTC