Piano experience was experiencing intermittent high latency on some requests
Incident Report for Piano
Resolved
We will continue monitoring
Posted about 2 years ago. Jul 12, 2017 - 15:41 EDT
Investigating
We are currently investigating this issue.
Posted about 2 years ago. Jul 12, 2017 - 14:22 EDT