[Piano Analytics] Incident supported by the on-call team

Incident Report for Piano Software

Resolved

The issue has been resolved and all Piano Analytics tools and interfaces are fully available.

We are currently catching up the delay in real-time data retrieval.
Posted May 28, 2025 - 05:32 UTC

Investigating

We are currently experiencing a production incident on Piano Analytics products.

Please excuse us for any inconvenience caused.
Posted May 28, 2025 - 05:17 UTC