A major incident has occurred with our cloud provider in the EU regions, impacting both streaming data ingestion and data consolidation processes. Our data collection and processing were not impacted.
Actions performed:
Once the provider service was restored, we checked the status of our system and restarted whatever needed to be restarted. Everything gradually returned to normal.
Actions to come:
We still need to address a few data transfer issues for specific customers on a case-by-case basis (particularly dataflow exports).
Everything should be back to normal by this morning.
Posted Dec 17, 2025 - 09:23 UTC
Resolved
The issue has been resolved and all (Piano Analytics) tools and interfaces are fully available. Some data still needs to be sent for some specific customers, but we will communicate with them directly.
Posted Dec 17, 2025 - 09:23 UTC
Identified
Our provider's service has been partially restored. Our teams are now actively working on completing the recovery on our side, including relaunching data loads and catching up on delayed processing.
Posted Dec 16, 2025 - 10:40 UTC
Update
We are continuing to investigate this issue.
Posted Dec 16, 2025 - 08:54 UTC
Investigating
We are currently experiencing a production incident on Piano Analytics products. A major incident is currently ongoing with our cloud provider in the EU regions, impacting both streaming data ingestion and data consolidation processes. Our data collection and processing are not impacted.
The issue started at approximately 03:30 UTC on December 16, 2025, and is still ongoing at this time on their side.
Please excuse us for any inconvenience caused.
Posted Dec 16, 2025 - 06:35 UTC
This incident affected: Data Processing (Piano Analytics Data Processing).