[Piano Analytics] Data alteration on src_ custom properties
Incident Report for Piano Software
Postmortem

Incident explanation:

  • The src_ custom properties were no longer using the visit scope in real time between 27/02/2024 and 05/03/2024.

Actions performed:

  • A fix has been released and data regeneration is complete.

Actions to come:

  • No more action needed.

Posted Mar 13, 2024 - 13:30 UTC

Resolved
The issue has been resolved.
All src_ custom properties now have the visit scope applied and data reprocessings on historical data 27/02/2024 - 05/03/2024 are complete.
Posted Mar 13, 2024 - 13:00 UTC
Investigating
We are currently experiencing altered data on src_ custom properties.
These properties are no longer using the visit scope in real time and recent historical data may be impacted.
Our technical teams are actively working to resolve the issue.
We apologize for any inconvenience caused.

Affected customers - Less than 1%
Posted Mar 05, 2024 - 10:50 UTC