Audience - API Failures happening in Europe environment.

Incident Report for Piano Software

Resolved

This incident has been resolved.
Posted May 29, 2026 - 03:53 UTC

Monitoring

A fix has been implemented and we are currently monitoring the results.

At this time, API performance has returned to normal operation levels and the platform is behaving as expected again.

We will continue monitoring closely to ensure stability.
Posted May 28, 2026 - 17:10 UTC

Identified

We identified an issue in our systems starting around 10:20 UTC that is currently degrading CXSense platform responsiveness over the /public/user/id endpoint.

As a result, some users may experience failed requests, while others may experience longer response times and timeouts.

Our engineering team is actively investigating and working on mitigation efforts. We will continue to provide updates as more information becomes available.
Posted May 28, 2026 - 16:27 UTC
This incident affected: API Availability (API Endpoints - cxense - api.cxense.com).