[Piano Analytics] Delays for some scheduled reports

Incident Report for Piano Software

Postmortem

Incident explanation:

  • Maintenance that was supposed to be transparent led to delays in sending some scheduled exports.

Actions performed:

  • Maintenance done without other issue.

Actions to come:

  • No more action needed.

Posted Jul 17, 2025 - 14:29 UTC

Resolved

The issue has been resolved and all exports have been sent.
Posted Jul 17, 2025 - 14:29 UTC

Investigating

We are currently experiencing delays in the generation of some scheduled exports.
Our technical teams are working to resolve this issue so that these exports may be sent as soon as possible.
We apologise for any inconvenience caused.

Affected customers - All customers
Posted Jul 17, 2025 - 13:42 UTC
This incident affected: Dashboards, Interfaces and Platform (Piano Analytics Exports, Piano Analytics Dataflow Exports).