Composer C1X segmentation issues (EU & US regions)

Incident Report for Piano Software

Resolved

The incident has been resolved.
Posted May 08, 2026 - 17:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2026 - 09:26 UTC

Investigating

Composer is experiencing a service incident affecting C1X segmentation in both EU and US regions. Impact includes high error rates, degraded segment lookup, and degraded widget performance. The issue started at approximately 22:00 UTC on May 7 and continues with periods of instability. Our team is actively investigating the issue.
Posted May 08, 2026 - 06:04 UTC
This incident affected: API Availability (API Endpoints - cxense - api.cxense.com) and Other.