[Activation] Composer segmentation issues (EU region)

Incident Report for Piano Software

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2026 - 08:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 15, 2026 - 06:54 UTC

Investigating

Composer is experiencing a service incident affecting Audience segments and Propensity Models in the EU region. Impact includes high error rates, degraded segment lookup, and degraded widget performance.
Posted Apr 15, 2026 - 05:14 UTC
This incident affects: API Availability (API Endpoints - cxense - api.cxense.com) and Other.