[Activation] Composer segmentation issues (EU region)

Incident Report for Piano Software

Resolved

The service disruption caused by a temporary load balancing issue has been fully resolved. We are deploying additional API server nodes to better handle future traffic spikes and prevent similar incidents.
Posted Apr 14, 2026 - 11:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 08:30 UTC

Investigating

Composer is experiencing a service incident affecting Audience segments and Propensity Models in the EU region. Impact includes high error rates, degraded segment lookup, and degraded widget performance.
Posted Apr 13, 2026 - 05:42 UTC
This incident affected: API Availability (API Endpoints - cxense - api.cxense.com) and Other.