[Piano Subscriptions] Reports issue (all regions)

Incident Report for Piano Software

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 12:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2026 - 10:59 UTC

Investigating

We are experiencing an issue with report generation. Our team is aware and actively working to resolve it.
Posted Aug 05, 2026 - 10:01 UTC
This incident affected: Other.