Elevated API Errors

Incident Report for Piano Software

Postmortem

RCA report for the incident can be found at this link.

Posted Jan 07, 2026 - 08:44 UTC

Resolved

The incident has been resolved.
Posted Dec 24, 2025 - 21:44 UTC

Monitoring

A fix has been implemented, and we're monitoring its results
Posted Dec 24, 2025 - 14:53 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 24, 2025 - 14:43 UTC

Investigating

Piano platform is experiencing an elevated level of API errors. Our engineers are currently looking into the issue.
Posted Dec 24, 2025 - 14:21 UTC
This incident affected: Dashboards, Interfaces and Platform (Publisher Dashboard - US - https://dashboard.piano.io), Payments (VX Checkout - US - buy.piano.io), API Availability (API Endpoints - US - api.piano.io), and Composer Experience Execution (Composer Experience Execution - US).