Mail Delivery delays
Incident Report for Piano Software
Resolved
This incident has been resolved.
Posted Jan 14, 2021 - 05:35 EST
Monitoring
Email sending is working, accumulated tasks are being processed now
Posted Jan 14, 2021 - 05:00 EST
Investigating
We are currently investigating this issue.
Posted Jan 14, 2021 - 04:20 EST
This incident affected: Email Distribution (Piano ESP Email Distribution).