[Piano Analytics] Incident supported by the on-call team

Incident Report for Piano Software

Postmortem

Explanation:

  • Alert on {region:eu-west-1} Lag on data enrichment service
  • Consequence: Real time delay

Actions:

  • Manually restarting the service on the affected instances seems to resolve the issue.
  • Scale up while continuing to restart the service on the remaining instances

Action to come:

  • No more action needed
Posted Feb 10, 2026 - 09:49 UTC

Resolved

The issue has been resolved and all Piano Analytics tools and interfaces are fully available.

We are currently catching up the delay in real-time data retrieval.
Posted Feb 10, 2026 - 07:24 UTC

Investigating

We are currently experiencing a production incident on Piano Analytics products.

Please excuse us for any inconvenience caused.
Posted Feb 10, 2026 - 06:54 UTC