Traffic drop - Piano Insight

Incident Report for Piano Software

Resolved

All systems have been restored and operating properly now.
Posted Nov 14, 2025 - 07:49 UTC

Monitoring

The issue has been resolved, and services are operating normally. We are continuing to monitor the situation to ensure ongoing stability.
Posted Nov 14, 2025 - 01:06 UTC

Update

The service stability has been fully restored across all regions except for Europe. Our teams continue to work diligently to restore the remaining region. Composer1x segmentation can still be affected, and the experience execution results might not be accurate because of that.
Posted Nov 13, 2025 - 22:01 UTC

Update

All traffic events were restored, team is now working on restoring stability on data cubes and depending services. Composer1x segmentation was affected and experience execution results might not be accurate because of that.
Posted Nov 13, 2025 - 13:09 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 13, 2025 - 12:48 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 13, 2025 - 12:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 13, 2025 - 09:54 UTC

Identified

We noticed a significant traffic drop in Insight started on November 12, 2025 17:07 UTC. Technical team identified the root cause and now working on the resolution.
Posted Nov 13, 2025 - 09:29 UTC
This incident affected: Composer Experience Execution (Composer Experience Execution - US, Composer Experience Execution - Europe), API Availability (API Endpoints - cxense - api.cxense.com), Data Collection (Insight Data collection), and Dashboards, Interfaces and Platform (Piano Insight Dashboard).