[Activation] Increased API Error Rate on ID Endpoints (US region)

Incident Report for Piano Software

Resolved

This incident has been resolved.
Posted May 05, 2026 - 08:21 UTC

Monitoring

Between 06:48 and 07:05 UTC, Piano ID API experienced elevated error rates in the US cluster. Requests requiring user authentication, token verification, and user profile retrieval were affected. Other Piano services including Composer and VX subscription management were not impacted. Service has been fully restored and all systems are operating normally.

We apologize for any disruption caused during this incident.
Posted May 05, 2026 - 08:21 UTC
This incident affected: Login and Registration (US - id.piano.io).