This incident has been resolved. The problem was caused by a compatibility issue between two system components that were running different versions. We have updated one of the components to ensure they work together properly, which has restored normal functionality.
Some users may need to clear their browser cache to fully resolve the issue and restore normal functionality.
We apologize for any disruption this issue may have caused.
Posted Apr 21, 2026 - 09:59 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 21, 2026 - 09:22 UTC
Investigating
We are currently investigating an issue affecting the publisher dashboard where users are unable to interact with the experience version dropdown and other buttons in Composer.
Posted Apr 21, 2026 - 09:00 UTC
This incident affected: Dashboards, Interfaces and Platform (Publisher Dashboard - US - https://dashboard.piano.io, Publisher Dashboard - Asia - https://dashboard-ap.piano.io, Publisher Dashboard - Australia - https://dashboard-au.piano.io, Publisher Dashboard - Europe - https://dashboard-eu.piano.io).