[Piano Analytics] Incident supported by the on-call team

Incident Report for Piano Software

Postmortem

Incident explanation:

  • Following the deletion of a site requested by a customer, one dataflow export was automatically deactivated.
    Only one customer was affected by this issue.

Actions done:

  • The site has been removed from the export, and the export has been reactivated.
    Missing data were resent.

Actions to do:

  • A redesign of the export planning system, currently underway, will prevent this from happening again in the future.
Posted Jun 03, 2025 - 14:35 UTC

Resolved

The issue has been resolved and all Piano Analytics tools and interfaces are fully available.

We are currently catching up the delay in real-time data retrieval.
Posted Jun 03, 2025 - 07:15 UTC

Investigating

We are currently experiencing a production incident on Piano Analytics products.

Please excuse us for any inconvenience caused.
Posted Jun 03, 2025 - 06:00 UTC