[Piano Analytics] Delay in generating yesterday's data

Incident Report for Piano Software

Postmortem

Incident explanation:

  • A data warehouse sizing issue with our provider caused delays in processing D-1 data.

Actions performed:

  • The processing has been relaunched.

Actions to come:

  • No more actions to come.

Posted May 15, 2025 - 12:35 UTC

Resolved

The issue has been resolved and all scheduled exports have been sent.
Posted May 15, 2025 - 12:35 UTC

Investigating

We are currently experiencing a delay in data generation for yesterday on Piano Analytics.
Scheduled exports may be still pending to be sent.
Our technical teams are actively working to resolve the issue.
Please excuse us for any inconvenience caused.

Affected customers - Less than 1%
Posted May 15, 2025 - 08:08 UTC
This incident affected: Data Processing (Piano Analytics Data Processing) and Dashboards, Interfaces and Platform (Piano Analytics Exports).