Email sending has been stopped
Incident Report for Piano Software
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 16:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2020 - 15:55 UTC
Investigating
We are currently investigating this issue.
Posted Nov 18, 2020 - 15:55 UTC
This incident affected: Email Distribution (Piano ESP Email Distribution).