[Identity Management] Login Failures

Incident Report for Piano Software

Monitoring

Piano has implemented a fix across all affected regions and environments, including Sandbox. Login and registration functionality has been restored and is operating normally. We will continue to monitor the situation and will provide a further update should any issues arise.
Posted Jul 27, 2026 - 09:20 UTC

Update

Piano can confirm this issue in fact only affects the US and EU regions, as well as Sandbox environment. AP and AU are not affected. We apologize for any confusion caused by the earlier update. Sandbox does not have a dedicated status page component since it's not part of production infrastructure, this update is provided for visibility. Our team continues to deploy the fix. We will share an update as soon as further information is available.
Posted Jul 27, 2026 - 08:57 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 27, 2026 - 08:35 UTC

Update

Piano has identified that this issue affects login and registration across all regions, not only the EU as initially reported. Users in all regions may experience the same symptoms — the login window failing to open, or becoming unresponsive. Our team continues to deploy the fix. We will share an update as soon as further information is available.

Affected components:
Registration + Login - US - id.piano.io
Registration + Login - Australia - id-au.piano.io
Registration + Login - Asia - id-ap.piano.io
Registration + Login - EU - id.piano.io
Posted Jul 27, 2026 - 08:34 UTC

Identified

Piano is experiencing an issue affecting login and registration for users in the EU region. The login window may fail to open, or may be unresponsive. We have identified the cause and our team is deploying a fix. We will share an update as soon as further information is available.
Posted Jul 27, 2026 - 08:30 UTC
This incident affects: Identity Management (Registration + Login - US - id.piano.io, Registration + Login - EU - id.piano.io).