Elevated server latency in Composer execution

Incident Report for Piano Software

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 10:42 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 23, 2026 - 17:50 UTC

Monitoring

The incident has been resolved. We will continue monitoring the latency on the backend servers.
Posted Apr 23, 2026 - 17:31 UTC

Identified

Composer is experiencing a latency incident affecting executions in the US region starting at 10 AM UTC. Impact includes timeouts and degraded performance.
Posted Apr 23, 2026 - 14:35 UTC
This incident affected: Composer Experience Execution (Composer Experience Execution - US).