[Piano Audience] SSL Certificate Errors Affecting Insight Access

Incident Report for Piano Software

Resolved

This incident has been resolved.
Posted Aug 15, 2026 - 09:24 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 15, 2026 - 09:12 UTC

Monitoring

Piano identified an issue affecting access to Piano Insight for some users. The certificate causing the errors has been renewed, and the fix has been verified internally. We are monitoring to confirm the issue is fully resolved and will share a further update shortly.
Posted Aug 15, 2026 - 09:00 UTC
This incident affected: Dashboards, Interfaces and Platform (Piano Audience - Insight).