[ESP] Email delivery delays (EU region)

Incident Report for Piano Software

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 19:44 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 17, 2025 - 19:44 UTC

Monitoring

A mitigation has been put in place by the email service provider. The email processing in the EU region is back to full working behavior.
Posted Mar 17, 2025 - 16:34 UTC

Identified

Piano ESP email delivery may be affected in the EU region due to an incident on the email service provider side. The incident can be monitored here: https://status.mailgun.com/incidents/b60dthm3t8gk
Posted Mar 17, 2025 - 10:12 UTC
This incident affected: Email Distribution (Piano ESP Email Distribution).