[Email Distribution] – Email and Push Notification Delivery Issues

Incident Report for Piano Software

Resolved

This incident has been resolved. Between 05:02 and 07:30 UTC, a network fault affecting a single server at our hosting provider's data centre disrupted the infrastructure responsible for email rendering, sending, feed imports, and scheduled tasks. Emails scheduled during this window were held and sent once service was restored, and content used in campaigns sent shortly after recovery may have reflected slightly older feed data than usual.
Posted Aug 24, 2026 - 09:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2026 - 07:54 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 24, 2026 - 07:47 UTC

Investigating

We are currently investigating an issue affecting the delivery of emails and push notifications for ESP users. Our engineering team is actively working to identify the root cause. We will share an update as soon as we have more information.
Posted Aug 24, 2026 - 05:08 UTC
This incident affected: Email Distribution (Piano ESP Email Distribution).