ID and VX Transaction Emails not being delivered due to Internal Mandrill Issue

Incident Report for Piano Software

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 08:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 03:32 UTC

Identified

Mandrill team has notified Piano about an issue impacting our account. Our team is currently coordinating efforts with the Mandrill account. The emails are queued but not getting delivered at the moment. We will continue to provide updates via this thread. Please monitor our status page for latest information.
Posted Apr 12, 2026 - 05:00 UTC
This incident affected: Email Distribution (Piano ID and VX transactional Emails).