[Activation] Publisher Dashboard degraded performance due to Cloudflare outage (US region)

Incident Report for Piano Software

Monitoring

The incident has been mitigated, along with our provider's resolution. We will continue to monitor the situation.
Posted Jun 22, 2026 - 17:30 UTC

Investigating

We are currently experiencing a minor service disruption affecting user logins to the Piano dashboards, caused by an ongoing outage on Cloudflare's side. Our team is actively monitoring the situation.

We apologize for any inconvenience this may cause and appreciate your patience. Further updates will be provided as soon as more information becomes available.

For reference: https://www.cloudflarestatus.com/incidents/v3yl7jqmqj51
Posted Jun 22, 2026 - 14:59 UTC
This incident affects: Dashboards, Interfaces and Platform (Publisher Dashboard - US - https://dashboard.piano.io).