[Piano Analytics] Data Manager data processing rules issue
Incident Report for Piano Software
Postmortem

Incident explanation:

  • A Data Manager release caused problems with rules.
  • Customers updating a Data Manager rule, an exclusion or a virtual site from this release had all their properties without a Data Manager rule.
  • Since the property can have false or empty values, the impact applies to data in the solution as well as to exports (CSV/Dashboards/Data Flow).

Actions performed:

  • A rollback was performed + a block was added to the pipeline to prevent this from happening again.
  • All data has been regenerated.

Actions to come:

  • Exports based on the wrong data will be re-sent.

Posted Feb 27, 2024 - 14:17 UTC

Resolved
All data regeneration is complete.
Exports based on the wrong data will be re-sent.
Posted Feb 27, 2024 - 14:17 UTC
Identified
We have fixed the issue. Incorrect data will be regenerated for all the impacted customers (less than 5%). Data regeneration will take place tomorrow (23/02) during the day.
Posted Feb 22, 2024 - 14:12 UTC
Investigating
We are currently experiencing an issue with Data Manager data processing rules on Piano Analytics.
Some rules may not be applied and raw collected data may be displayed in the interfaces.
Our technical teams are actively working to resolve the issue.
We apologize for any inconvenience caused.

Affected customers - Less than 5%
Posted Feb 22, 2024 - 13:11 UTC
This incident affected: Data Processing (Piano Analytics Data Processing).